[SCHANNEL]
[reactos.git] / reactos / dll / win32 / schannel / CMakeLists.txt
index de83c95..6abf304 100644 (file)
@@ -1,23 +1,30 @@
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-add_definitions(-D__WINESRC__)
 
-set_rc_compiler()
+include_directories(
+    ${REACTOS_SOURCE_DIR}/include/reactos/wine
+    ${REACTOS_SOURCE_DIR}/include/reactos/libs/gnutls)
+
+
+add_definitions(-D__WINESRC__ -D_WINE)
 spec2def(schannel.dll schannel.spec)
 
 list(APPEND SOURCE
     lsamode.c
+    schannel_gnutls.c
     schannel_main.c
+    schannel_wine.c
+    secur32_wine.c
     usermode.c
+    stubs.c
+    precomp.h
+    ${CMAKE_CURRENT_BINARY_DIR}/schannel_stubs.c)
+
+add_library(schannel SHARED
+    ${SOURCE}
     version.rc
-    ${CMAKE_CURRENT_BINARY_DIR}/schannel_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/schannel.def)
 
-add_library(schannel SHARED ${SOURCE})
-
 set_module_type(schannel win32dll)
-
 target_link_libraries(schannel wine)
-
-add_importlibs(schannel secur32 msvcrt kernel32 ntdll)
-
+add_importlibs(schannel crypt32 advapi32 msvcrt kernel32 ntdll)
+add_pch(schannel precomp.h SOURCE)
 add_cd_file(TARGET schannel DESTINATION reactos/system32 FOR all)