[SHELL32]
[reactos.git] / reactos / dll / win32 / shell32 / CMakeLists.txt
index 3c2ab5a..2a4f68e 100644 (file)
@@ -6,6 +6,11 @@ add_subdirectory(shellmenu)
 set_cpp(WITH_RUNTIME)
 spec2def(shell32.dll shell32.spec ADD_IMPORTLIB)
 
+if(NOT MSVC)
+    # HACK: this should be enabled globally!
+    add_compile_flags_language("-std=c++11" "CXX")
+endif()
+
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
@@ -53,6 +58,7 @@ list(APPEND SOURCE
     shlfolder.cpp
     CFileSysBindData.cpp
     CDefView.cpp
+    CDefViewDual.cpp
     stubs.cpp
     systray.cpp
     CDefaultContextMenu.cpp