[SHELL/EXPERIMENTS]
[reactos.git] / reactos / dll / win32 / shlwapi / CMakeLists.txt
diff --git a/reactos/dll/win32/shlwapi/CMakeLists.txt b/reactos/dll/win32/shlwapi/CMakeLists.txt
deleted file mode 100644 (file)
index f760833..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-
-add_definitions(
-    -D__WINESRC__
-    -D_SHLWAPI_)
-
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-spec2def(shlwapi.dll shlwapi.spec ADD_IMPORTLIB)
-
-list(APPEND SOURCE
-    assoc.c
-    clist.c
-    istream.c
-    msgbox.c
-    ordinal.c
-    path.c
-    reg.c
-    regstream.c
-    shlwapi_main.c
-    stopwatch.c
-    string.c
-    thread.c
-    url.c
-    wsprintf.c
-    ${CMAKE_CURRENT_BINARY_DIR}/shlwapi_stubs.c
-    ${CMAKE_CURRENT_BINARY_DIR}/shlwapi.def)
-
-add_library(shlwapi SHARED ${SOURCE} shlwapi.rc)
-set_module_type(shlwapi win32dll)
-target_link_libraries(shlwapi uuid wine)
-add_delay_importlibs(shlwapi userenv oleaut32 ole32 comdlg32 mpr mlang urlmon shell32 winmm version)
-add_importlibs(shlwapi user32 gdi32 advapi32 wininet msvcrt kernel32 ntdll)
-add_cd_file(TARGET shlwapi DESTINATION reactos/system32 FOR all)