[SHLWAPI] Implement AssocGetPerceivedType. By Mark Jansen. CORE-9754
[reactos.git] / reactos / dll / win32 / shlwapi / CMakeLists.txt
index e5768b4..0efadaa 100644 (file)
@@ -1,11 +1,14 @@
 
 project(SHELL)
 
+remove_definitions(-D_WIN32_WINNT=0x502)
+add_definitions(-D_WIN32_WINNT=0x600)
+
 add_definitions(
     -D__WINESRC__
     -D_SHLWAPI_)
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
+include_directories(BEFORE ${REACTOS_SOURCE_DIR}/include/reactos/wine)
 spec2def(shlwapi.dll shlwapi.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
@@ -17,6 +20,7 @@ list(APPEND SOURCE
     path.c
     reg.c
     regstream.c
+    rosordinal.c
     shlwapi_main.c
     stopwatch.c
     string.c