[FSLIB]: Minor fixes:
[reactos.git] / reactos / dll / win32 / ufatx / CMakeLists.txt
index 927efb5..9f7ce36 100644 (file)
@@ -2,12 +2,12 @@
 spec2def(ufatx.dll ufatx.spec)
 
 list(APPEND SOURCE
+    ufatx.c
     ufatx.rc
     ${CMAKE_CURRENT_BINARY_DIR}/ufatx.def)
 
 add_library(ufatx SHARED ${SOURCE})
+set_module_type(ufatx nativedll)
 target_link_libraries(ufatx vfatxlib)
-set_module_type(ufatx nativedll ENTRYPOINT 0 )
 add_importlibs(ufatx ntdll)
-add_dependencies(ufatx psdk)
 add_cd_file(TARGET ufatx DESTINATION reactos/system32 FOR all)