[USP10]
[reactos.git] / reactos / dll / win32 / usp10 / CMakeLists.txt
index 17b66b1..b9af555 100644 (file)
@@ -1,25 +1,24 @@
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 add_definitions(-D__WINESRC__)
-
-spec2def(usp10.dll usp10.spec)
+spec2def(usp10.dll usp10.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
     bidi.c
-    usp10.c
+    breaking.c
+    indic.c
+    indicsyllable.c
+    linebreak.c
     mirror.c
+    opentype.c
     shape.c
     shaping.c
+    usp10.c
     ${CMAKE_CURRENT_BINARY_DIR}/usp10_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/usp10.def)
 
 add_library(usp10 SHARED ${SOURCE})
-
 set_module_type(usp10 win32dll)
-
 target_link_libraries(usp10 wine)
-
-add_importlibs(usp10 gdi32 msvcrt kernel32 ntdll)
-add_importlib_target(usp10.spec)
-
+add_importlibs(usp10 advapi32 user32 gdi32 msvcrt kernel32 ntdll)
 add_cd_file(TARGET usp10 DESTINATION reactos/system32 FOR all)