[WBEMPROX] Sync with Wine Staging 1.9.4. CORE-10912
[reactos.git] / reactos / dll / win32 / wbemprox / CMakeLists.txt
index aee2221..ef85cf1 100644 (file)
@@ -3,7 +3,7 @@ remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
 add_definitions(-D__WINESRC__)
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
+include_directories(BEFORE ${REACTOS_SOURCE_DIR}/include/reactos/wine)
 spec2def(wbemprox.dll wbemprox.spec)
 
 list(APPEND SOURCE
@@ -14,17 +14,24 @@ list(APPEND SOURCE
     qualifier.c
     query.c
     reg.c
+    security.c
     service.c
     services.c
     table.c
     wbemlocator.c
     wql.tab.c
+    wbemprox_private.h)
+
+add_library(wbemprox SHARED
+    ${SOURCE}
+    guid.c
+    wbemprox.rc
     ${CMAKE_CURRENT_BINARY_DIR}/wbemprox.def)
 
-add_library(wbemprox SHARED ${SOURCE} wbemprox.rc)
 set_source_files_properties(wbemprox.rc PROPERTIES OBJECT_DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/wbemprox.rgs)
 set_module_type(wbemprox win32dll)
-target_link_libraries(wbemprox wine)
-add_importlibs(wbemprox iphlpapi dxgi oleaut32 advapi32 user32 gdi32 version msvcrt kernel32 ntdll)
+target_link_libraries(wbemprox uuid wine)
+add_importlibs(wbemprox iphlpapi oleaut32 advapi32 user32 gdi32 version winspool ws2_32 rpcrt4 msvcrt kernel32 ntdll)
 add_dependencies(wbemprox d3d_idl_headers)
+add_pch(wbemprox wbemprox_private.h SOURCE)
 add_cd_file(TARGET wbemprox DESTINATION reactos/system32/wbem FOR all)