[WSHTCPIP]
[reactos.git] / reactos / dll / win32 / wshtcpip / CMakeLists.txt
index bea0689..e0c94ac 100644 (file)
@@ -1,5 +1,4 @@
 
-set_unicode()
 
 include_directories(${REACTOS_SOURCE_DIR}/lib/tdilib)
 
@@ -12,9 +11,9 @@ list(APPEND SOURCE
 
 add_library(wshtcpip SHARED ${SOURCE})
 
-set_entrypoint(wshtcpip 0)
+set_module_type(wshtcpip win32dll UNICODE)
 
 target_link_libraries(wshtcpip tdilib)
-add_importlibs(wshtcpip ws2_32 kernel32 ntdll)
+add_importlibs(wshtcpip ws2_32 msvcrt kernel32 ntdll)
 add_dependencies(wshtcpip psdk)
 add_cd_file(TARGET wshtcpip DESTINATION reactos/system32 FOR all)