[DRIVERS]
[reactos.git] / reactos / drivers / bus / acpi / compbatt / CMakeLists.txt
index 8923c64..f85e15b 100644 (file)
@@ -3,14 +3,16 @@ list(APPEND SOURCE
     compbatt.c
     compmisc.c
     comppnp.c
+    compbatt.h)
+
+add_library(compbatt SHARED
+    ${SOURCE}
     guid.c
     compbatt.rc)
 
-add_library(compbatt SHARED ${SOURCE})
-
 set_module_type(compbatt kernelmodedriver)
 add_importlibs(compbatt ntoskrnl hal battc)
 
-add_pch(compbatt compbatt.h)
+add_pch(compbatt compbatt.h SOURCE)
 
 add_cd_file(TARGET compbatt DESTINATION reactos/system32/drivers FOR all)