Added missing .cvsignore files.
[reactos.git] / reactos / drivers / dd / blue / makefile
index 833a9a4..356e650 100644 (file)
@@ -1,20 +1,22 @@
-# $Id: makefile,v 1.17 2001/07/15 21:18:57 rex Exp $
+# $Id: makefile,v 1.18 2001/07/25 06:19:34 ekohl Exp $
 #
 #
 PATH_TO_TOP = ../../..
 
 TARGET = blue
 
-CFLAGS = -D__NTDRIVER__ -I../../../include
+CFLAGS = -D__NTDRIVER__
 
-OBJECTS = $(TARGET).o $(TARGET).coff ../../../ntoskrnl/ntoskrnl.a
+OBJECTS = $(TARGET).o $(TARGET).coff 
+
+LIBS = $(PATH_TO_TOP)/ntoskrnl/ntoskrnl.a
 
 all: $(TARGET).sys $(TARGET).sys.unstripped
 
 .phony: all
 
 clean:
-       - $(RM) $(TARGET).o $(TARGET).coff junk.tmp base.tmp temp.exp blue.sys blue.sys.unstripped
+       - $(RM) *.o *.sym $(TARGET).coff junk.tmp base.tmp temp.exp blue.sys blue.sys.unstripped
 
 .phony: clean
 
@@ -23,12 +25,12 @@ install: $(FLOPPY_DIR)/drivers/$(TARGET).sys
 $(FLOPPY_DIR)/drivers/$(TARGET).sys: $(TARGET).sys
        $(CP) $(TARGET).sys $(FLOPPY_DIR)/drivers/$(TARGET).sys
 
-dist: ../../../$(DIST_DIR)/drivers/$(TARGET).sys
+dist: $(PATH_TO_TOP)/$(DIST_DIR)/drivers/$(TARGET).sys
 
-../../../$(DIST_DIR)/drivers/$(TARGET).sys: $(TARGET).sys
-       $(CP) $(TARGET).sys ../../../$(DIST_DIR)/drivers/$(TARGET).sys
+$(PATH_TO_TOP)/$(DIST_DIR)/drivers/$(TARGET).sys: $(TARGET).sys
+       $(CP) $(TARGET).sys $(PATH_TO_TOP)/$(DIST_DIR)/drivers/$(TARGET).sys
 
-$(TARGET).sys $(TARGET).sys.unstripped: $(OBJECTS)
+$(TARGET).sys $(TARGET).sys.unstripped: $(OBJECTS) $(LIBS)
 
 WARNINGS_ARE_ERRORS = yes
-include ../../../rules.mak
+include $(PATH_TO_TOP)/rules.mak