Added missing .cvsignore files.
[reactos.git] / reactos / drivers / dd / ide / makefile
index 06803f5..3c88a81 100644 (file)
@@ -1,11 +1,13 @@
-# $Id: makefile,v 1.23 2001/07/15 21:18:57 rex Exp $
+# $Id: makefile,v 1.24 2001/07/25 06:20:01 ekohl Exp $
 #
 #
 PATH_TO_TOP = ../../..
 
 TARGET=ide
 
-OBJECTS = $(TARGET).o $(TARGET).coff ../../../ntoskrnl/ntoskrnl.a
+OBJECTS = $(TARGET).o $(TARGET).coff
+
+LIBS = $(PATH_TO_TOP)/ntoskrnl/ntoskrnl.a
 
 CFLAGS = -D__NTDRIVER__ -I. -g
 
@@ -14,7 +16,7 @@ all: $(TARGET).sys.unstripped $(TARGET).sys
 .phony: all
 
 clean:
-       - $(RM) $(TARGET).o $(TARGET).coff junk.tmp base.tmp temp.exp $(TARGET).sys $(TARGET).sys.unstripped
+       - $(RM) *.o *.sym $(TARGET).coff junk.tmp base.tmp temp.exp $(TARGET).sys $(TARGET).sys.unstripped
 
 .phony: clean
 
@@ -23,13 +25,13 @@ install: $(FLOPPY_DIR)/drivers/$(TARGET).sys
 $(FLOPPY_DIR)/drivers/$(TARGET).sys: $(TARGET).sys
        $(CP) $(TARGET).sys $(FLOPPY_DIR)/drivers/$(TARGET).sys
 
-dist: ../../../$(DIST_DIR)/drivers/$(TARGET).sys
+dist: $(PATH_TO_TOP)/$(DIST_DIR)/drivers/$(TARGET).sys
 
-../../../$(DIST_DIR)/drivers/$(TARGET).sys: $(TARGET).sys
-       $(CP) $(TARGET).sys ../../../$(DIST_DIR)/drivers/$(TARGET).sys
+$(PATH_TO_TOP)/$(DIST_DIR)/drivers/$(TARGET).sys: $(TARGET).sys
+       $(CP) $(TARGET).sys $(PATH_TO_TOP)/$(DIST_DIR)/drivers/$(TARGET).sys
 
-$(TARGET).sys $(TARGET).sys.unstripped: $(OBJECTS)
+$(TARGET).sys $(TARGET).sys.unstripped: $(OBJECTS) $(LIBS)
 
 WITH_DEBUGGING=yes
 WARNINGS_ARE_ERRORS = yes
-include ../../../rules.mak
+include $(PATH_TO_TOP)/rules.mak