Added missing .cvsignore files.
[reactos.git] / reactos / drivers / dd / test / makefile
index 37bfdc8..6c36329 100644 (file)
@@ -3,27 +3,33 @@
 #
 PATH_TO_TOP = ../../..
 
-OBJECTS= test.o ../../../ntoskrnl/ntoskrnl.a
+TARGET = test
 
-all: test.sys
+OBJECTS = test.o
+
+LIBS = $(PATH_TO_TOP)/ntoskrnl/ntoskrnl.a
+
+CFLAGS =
+
+all: $(TARGET).sys $(TARGET).sys.unstripped
 
 .phony: all
 
 clean:
-       - $(RM) test.o test.a junk.tmp base.tmp temp.exp test.sys
+       - $(RM) *.o *.sym *.coff junk.tmp base.tmp temp.exp $(TARGET).sys $(TARGET).sys.unstripped
 
 .phony: clean
 
-test.sys: test.o
-       $(DLLTOOL) --dllname test.sys --output-lib test.a
-       $(CC) -specs=$(KM_SPECS) -mdll -o junk.tmp -Wl,--defsym,_end=end \
-             -Wl,--defsym,_edata=__data_end__ -Wl,--defsym,_etext=etext \
-             -Wl,--base-file,base.tmp $(OBJECTS)
-       - $(RM) junk.tmp
-       $(DLLTOOL) --dllname test.sys --base-file base.tmp \
-                  --output-exp temp.exp 
-       - $(RM) base.tmp
-       $(CC) --verbose -Wl,--image-base,0x10000 -Wl,-e,_DriverEntry -specs=$(KM_SPECS) \
-               -mdll -o test.sys $(OBJECTS) -Wl,temp.exp
-       - $(RM) temp.exp
+install: $(FLOPPY_DIR)/drivers/$(TARGET).sys
+
+$(FLOPPY_DIR)/drivers/$(TARGET).sys: $(TARGET).sys
+       $(CP) $(TARGET).sys $(FLOPPY_DIR)/drivers/$(TARGET).sys
+
+dist: $(PATH_TO_TOP)/$(DIST_DIR)/drivers/$(TARGET).sys
+
+$(PATH_TO_TOP)/$(DIST_DIR)/drivers/$(TARGET).sys: $(TARGET).sys
+       $(CP) $(TARGET).sys $(PATH_TO_TOP)/$(DIST_DIR)/drivers/$(TARGET).sys
+
+$(TARGET).sys $(TARGET).sys.unstripped: $(OBJECTS) $(LIBS)
 
+include $(PATH_TO_TOP)/rules.mak