[FLTMGR]
[reactos.git] / reactos / drivers / filters / fltmgr / CMakeLists.txt
diff --git a/reactos/drivers/filters/fltmgr/CMakeLists.txt b/reactos/drivers/filters/fltmgr/CMakeLists.txt
new file mode 100644 (file)
index 0000000..2ab706a
--- /dev/null
@@ -0,0 +1,14 @@
+
+list(APPEND SOURCE
+    Interface.c
+    Registration.c
+    Object.c
+    Lib.c
+    fltmgr.h)
+
+add_library(rosfltmgr SHARED ${SOURCE} fltmgr.rc)
+set_module_type(rosfltmgr kernelmodedriver)
+target_link_libraries(rosfltmgr ${PSEH_LIB})
+add_importlibs(rosfltmgr ntoskrnl hal)
+add_pch(rosfltmgr fltmgr.h SOURCE)
+add_cd_file(TARGET rosfltmgr DESTINATION reactos/system32/drivers NO_CAB FOR all)