[WSHTCPIP]
[reactos.git] / reactos / drivers / network / tcpip / CMakeLists.txt
index 30dac48..5a8230a 100644 (file)
@@ -14,6 +14,7 @@ list(APPEND SOURCE
     datalink/lan.c
     tcpip/ainfo.c
     tcpip/buffer.c
+    tcpip/cinfo.c
     tcpip/dispatch.c
     tcpip/fileobjs.c
     tcpip/iinfo.c
@@ -24,11 +25,13 @@ list(APPEND SOURCE
     tcpip/proto.c
     tcpip/tinfo.c
     tcpip/wait.c
+    include/precomp.h)
+
+add_library(tcpip SHARED
+    ${SOURCE}
     tcpip.rc
     ${CMAKE_CURRENT_BINARY_DIR}/tcpip.def)
 
-add_library(tcpip SHARED ${SOURCE})
-
 target_link_libraries(tcpip
     ip
     lwip
@@ -38,6 +41,6 @@ target_link_libraries(tcpip
 set_module_type(tcpip kernelmodedriver)
 add_importlibs(tcpip ndis ntoskrnl hal)
 
-add_pch(tcpip include/precomp.h)
+add_pch(tcpip include/precomp.h SOURCE)
 
 add_cd_file(TARGET tcpip DESTINATION reactos/system32/drivers FOR all)