[APPHELP_APITEST] Add tests for SdbGetMatchingExe, to test matching on version resour...
[reactos.git] / reactos / drivers / storage / classpnp / CMakeLists.txt
index 6632c40..a5df7f6 100644 (file)
@@ -1,5 +1,6 @@
 
 include_directories(../inc)
+spec2def(classpnp.sys classpnp.spec ADD_IMPORTLIB)
 
 add_definitions(
     -DCLASS_GLOBAL_BREAK_ON_LOST_IRPS=0
@@ -9,8 +10,6 @@ add_definitions(
     -DCLASS_GLOBAL_BUFFERED_DEBUG_PRINT_BUFFER_SIZE=512
     -DCLASS_GLOBAL_BUFFERED_DEBUG_PRINT_BUFFERS=512)
 
-spec2def(classpnp.sys classpnp.spec ADD_IMPORTLIB)
-
 list(APPEND SOURCE
     autorun.c
     class.c
@@ -26,25 +25,16 @@ list(APPEND SOURCE
     retry.c
     utils.c
     xferpkt.c
-    ${CMAKE_CURRENT_BINARY_DIR}/classpnp.def)
+    classp.h)
 
 add_library(classpnp SHARED
     ${SOURCE}
-    class.rc)
-
-if(ARCH MATCHES i386)
-    # FIXME: http://www.cmake.org/Bug/view.php?id=12998
-    if(MSVC)
-        #add_target_compile_flags(classpnp "/Gz")
-        set_source_files_properties(${SOURCE} PROPERTIES COMPILE_FLAGS "/Gz")
-    else()
-        set_source_files_properties(${SOURCE} PROPERTIES COMPILE_FLAGS "-w")
-    endif()
-endif()
+    guid.c
+    class.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/classpnp.def)
 
-add_pch(classpnp classp.h)
+add_pch(classpnp classp.h SOURCE)
 target_link_libraries(classpnp ${PSEH_LIB} libcntpr)
 set_module_type(classpnp kernelmodedriver)
 add_importlibs(classpnp hal ntoskrnl)
-
 add_cd_file(TARGET classpnp DESTINATION reactos/system32/drivers NO_CAB FOR all)