[USBHUB_NEW] Bring-in the USB Hub driver created by Vadim Galyant. GitHub PR #29...
[reactos.git] / reactos / drivers / usb / usbhub_new / CMakeLists.txt
diff --git a/reactos/drivers/usb/usbhub_new/CMakeLists.txt b/reactos/drivers/usb/usbhub_new/CMakeLists.txt
new file mode 100644 (file)
index 0000000..a1355df
--- /dev/null
@@ -0,0 +1,22 @@
+
+add_definitions(-DDEBUG_MODE)
+include_directories(${REACTOS_SOURCE_DIR}/ntoskrnl/include)
+
+list(APPEND SOURCE
+    debug.c
+    ioctl.c
+    pnp.c
+    power.c
+    usbhub.c
+    usbhub.h)
+
+add_library(usbhub SHARED
+    ${SOURCE}
+    guid.c
+    usbhub.rc)
+
+target_link_libraries(usbhub ${PSEH_LIB})
+set_module_type(usbhub kernelmodedriver)
+add_importlibs(usbhub ntoskrnl hal wmilib usbd)
+add_pch(usbhub usbhub.h SOURCE)
+add_cd_file(TARGET usbhub DESTINATION reactos/system32/drivers NO_CAB FOR all)