[PSDK]
[reactos.git] / reactos / include / psdk / CMakeLists.txt
index 53e1874..6c915b0 100644 (file)
@@ -12,10 +12,13 @@ list(APPEND SOURCE
 #   asynot.idl
 #   asysta.idl
     atliface.idl
+    audioclient.idl
+    audiopolicy.idl
     bdaiface.idl
 #   binres.idl
     bits.idl
     bits1_5.idl
+    bits3_0.idl
 #   cmdbas.idl
 #   cmdtxt.idl
     comcat.idl
@@ -32,14 +35,19 @@ list(APPEND SOURCE
 #   dbprop.idl
 #   dbs.idl
     devenum.idl
+    devicetopology.idl
     dimm.idl
     dispex.idl
     docobj.idl
+    docobjectservice.idl
     downloadmgr.idl
+    dxgi.idl
 #   dyngraph.idl
+    endpointvolume.idl
     exdisp.idl
     fusion.idl
     hlink.idl
+    htiface.idl
     htiframe.idl
     httprequest.idl
     iads.idl
@@ -47,10 +55,12 @@ list(APPEND SOURCE
     imnact.idl
     imnxport.idl
     indexsrv.idl
+    inputscope.idl
     metahost.idl
     mimeinfo.idl
     mimeole.idl
     mlang.idl
+    mmdeviceapi.idl
     mscoree.idl
     msctf.idl
     msdadc.idl
@@ -95,6 +105,7 @@ list(APPEND SOURCE
     strmif.idl
     structuredquerycondition.idl
     textstor.idl
+    tlogstg.idl
     tom.idl
     tuner.idl
     unknwn.idl
@@ -102,9 +113,13 @@ list(APPEND SOURCE
     urlmon.idl
     vmr9.idl
 #   vmrender.idl
+    wbemcli.idl
+    wbemdisp.idl
+    wbemprov.idl
     wia_lh.idl
     wia_xp.idl
     wincodec.idl
+    wincodecsdk.idl
     winsxs.idl
     wtypes.idl
     wuapi.idl
@@ -113,16 +128,13 @@ list(APPEND SOURCE
     ctfutb.idl
     xmllite.idl)
 
-if(NOT MSVC)
-  list(APPEND SOURCE
-    wbemcli.idl)
-endif()
-
 add_idl_headers(psdk ${SOURCE})
-
 add_typelib(stdole2.idl)
 add_custom_target(stdole2 DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/stdole2.tlb)
 
+add_idl_headers(d3d_idl_headers d3d10.idl d3dcommon.idl)
+
+add_iid_library(dxgi_uuids dxgi.idl)
 add_iid_library(wuguid wuapi.idl)
 add_iid_library(xml_uuids msxml2.idl)