[FULLFAT]
[reactos.git] / reactos / lib / 3rdparty / fullfat / CMakeLists.txt
index 657abdd..5865a3c 100644 (file)
@@ -1,6 +1,5 @@
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/libs/fullfat)
-
 add_definitions(-D__NTDRIVER__)
 
 list(APPEND SOURCE
@@ -18,3 +17,9 @@ list(APPEND SOURCE
     ff_time.c)
 
 add_library(fullfat ${SOURCE})
+allow_warnings(fullfat)
+add_dependencies(fullfat bugcodes)
+
+if(NOT MSVC)
+    add_target_compile_flags(fullfat "-Wno-unused-but-set-variable")
+endif()