Merge r68232 to get Windows' rpcrt4.dll to work under ReactOS.
[reactos.git] / reactos / lib / rtl / CMakeLists.txt
index 46b17c2..e9dfcda 100644 (file)
@@ -9,6 +9,7 @@ list(APPEND SOURCE
     access.c
     acl.c
     actctx.c
+    appverifier.c
     assert.c
     atom.c
     avltable.c
@@ -30,8 +31,10 @@ list(APPEND SOURCE
     heap.c
     heapdbg.c
     heappage.c
+    heapuser.c
     image.c
     interlck.c
+    memstream.c
     message.c
     largeint.c
     luid.c
@@ -47,6 +50,7 @@ list(APPEND SOURCE
     registry.c
     res.c
     resource.c
+    rxact.c
     sd.c
     security.c
     slist.c
@@ -62,7 +66,8 @@ list(APPEND SOURCE
     vectoreh.c
     version.c
     wait.c
-    workitem.c)
+    workitem.c
+    rtl.h)
 
 if(ARCH STREQUAL "i386")
     list(APPEND ASM_SOURCE
@@ -81,6 +86,7 @@ elseif(ARCH STREQUAL "amd64")
         amd64/except_asm.S
         amd64/slist.S)
     list(APPEND SOURCE
+        bitmap64.c
         byteswap.c
         amd64/unwind.c
         amd64/stubs.c
@@ -104,5 +110,5 @@ endif()
 
 add_asm_files(rtl_asm ${ASM_SOURCE})
 add_library(rtl ${SOURCE} ${rtl_asm})
-add_pch(rtl rtl.h)
+add_pch(rtl rtl.h SOURCE)
 add_dependencies(rtl psdk asm)