[Win32SS]
[reactos.git] / reactos / win32ss / CMakeLists.txt
index 88c74d2..24477f2 100644 (file)
@@ -129,11 +129,13 @@ list(APPEND SOURCE
     user/ntuser/monitor.c
     user/ntuser/mouse.c
     user/ntuser/msgqueue.c
+    user/ntuser/nonclient.c
     user/ntuser/ntstubs.c
     user/ntuser/ntuser.c
     user/ntuser/painting.c
     user/ntuser/prop.c
     user/ntuser/scrollbar.c
+    user/ntuser/scrollex.c
     user/ntuser/session.c
     user/ntuser/shutdown.c
     user/ntuser/simplecall.c
@@ -151,7 +153,6 @@ list(APPEND SOURCE
     gdi/ntgdi/bezier.c
     gdi/ntgdi/bitblt.c
     gdi/ntgdi/bitmaps.c
-    gdi/ntgdi/brush.cpp
     gdi/ntgdi/cliprgn.c
     gdi/ntgdi/coord.c
     gdi/ntgdi/dcattr.c
@@ -220,6 +221,7 @@ add_asm_files(win32k_asm ${ASM_SOURCE})
 
 add_library(win32k SHARED
     ${SOURCE}
+    gdi/ntgdi/brush.cpp
     ${win32k_asm}
     win32k.rc
     ${CMAKE_CURRENT_BINARY_DIR}/win32k.def)
@@ -232,7 +234,7 @@ if(USE_DIBLIB)
 endif()
 
 add_importlibs(win32k ntoskrnl hal ftfd)
-#add_pch(win32k pch.h SOURCE)
+add_pch(win32k pch.h SOURCE)
 add_cd_file(TARGET win32k DESTINATION reactos/system32 FOR all)
 
 set_source_files_properties(sys-stubs.S PROPERTIES OBJECT_DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/w32ksvc.h)