[UXTHEME] Greatly reduce the number of times we open the theme data for the non clien...
[reactos.git] / reactos / win32ss / CMakeLists.txt
index d354590..fec1a74 100644 (file)
@@ -27,9 +27,9 @@ include_directories(
     .
     include
     ${REACTOS_SOURCE_DIR}/ntoskrnl/include
-    ${REACTOS_SOURCE_DIR}/lib/3rdparty/freetype/include
-    ${REACTOS_SOURCE_DIR}/include/reactos/subsys
-    ${REACTOS_SOURCE_DIR}/include/reactos/drivers)
+    ${REACTOS_SOURCE_DIR}/sdk/lib/3rdparty/freetype/include
+    ${REACTOS_SOURCE_DIR}/sdk/include/reactos/subsys
+    ${REACTOS_SOURCE_DIR}/sdk/include/reactos/drivers)
 
 add_definitions(
     -DLANGPACK
@@ -123,6 +123,7 @@ list(APPEND SOURCE
     user/ntuser/ime.c
     user/ntuser/keyboard.c
     user/ntuser/kbdlayout.c
+    user/ntuser/layered.c
     user/ntuser/menu.c
     user/ntuser/message.c
     user/ntuser/metric.c
@@ -130,11 +131,13 @@ list(APPEND SOURCE
     user/ntuser/monitor.c
     user/ntuser/mouse.c
     user/ntuser/msgqueue.c
+    user/ntuser/nonclient.c
     user/ntuser/ntstubs.c
     user/ntuser/ntuser.c
     user/ntuser/painting.c
     user/ntuser/prop.c
     user/ntuser/scrollbar.c
+    user/ntuser/scrollex.c
     user/ntuser/session.c
     user/ntuser/shutdown.c
     user/ntuser/simplecall.c
@@ -148,6 +151,7 @@ list(APPEND SOURCE
     user/ntuser/winpos.c
     user/ntuser/winsta.c
     user/ntuser/object.c
+    user/rtl/text.c
     gdi/ntgdi/arc.c
     gdi/ntgdi/bezier.c
     gdi/ntgdi/bitblt.c