[WIN32SS]
[reactos.git] / reactos / win32ss / drivers / displays / framebuf_new / CMakeLists.txt
index 250a391..861778d 100644 (file)
@@ -7,16 +7,17 @@ list(APPEND SOURCE
     palette.c
     pointer.c
     screen.c
-    ${CMAKE_CURRENT_BINARY_DIR}/framebuf_new.def)
+    driver.h)
 
 add_library(framebuf_new SHARED
     ${SOURCE}
-    framebuf_new.rc)
+    framebuf_new.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/framebuf_new.def)
 
 set_entrypoint(framebuf_new DrvEnableDriver 12)
 set_subsystem(framebuf_new native)
 set_image_base(framebuf_new 0x00010000)
 target_link_libraries(framebuf_new libcntpr)
 add_importlibs(framebuf_new win32k)
-add_pch(framebuf_new driver.h)
+add_pch(framebuf_new driver.h SOURCE)
 add_dependencies(framebuf_new psdk bugcodes)