[CRT][GDI32] Introduce atan2 library, use it for gdi32 to fix a crash. CORE-11521
[reactos.git] / reactos / win32ss / gdi / gdi32 / CMakeLists.txt
index f2ee241..527c8f8 100644 (file)
@@ -1,4 +1,8 @@
 
+add_subdirectory(wine)
+
+add_definitions(-DLANGPACK)
+
 include_directories(
     include
     ${REACTOS_SOURCE_DIR}/win32ss/include)
@@ -46,8 +50,20 @@ add_library(gdi32 SHARED
     gdi32.rc
     ${CMAKE_CURRENT_BINARY_DIR}/gdi32.def)
 
-set_module_type(gdi32 win32dll ENTRYPOINT DllMain 12 UNICODE)
-target_link_libraries(gdi32 win32ksys dxguid msvcrtex ${PSEH_LIB})
+set_module_type(gdi32
+    win32dll
+    ENTRYPOINT DllMain 12
+    UNICODE)
+
+target_link_libraries(gdi32
+    winegdi
+    wine 
+    win32ksys
+    dxguid
+    msvcrtex
+    atan2
+    ${PSEH_LIB})
+
 add_importlibs(gdi32 user32 advapi32 kernel32 ntdll)
 add_pch(gdi32 include/precomp.h SOURCE)
 add_cd_file(TARGET gdi32 DESTINATION reactos/system32 FOR all)