Time to commit some Work-In-Progress stuff before my diff gets too large..
[reactos.git] / reactos / win32ss / printing / providers / localspl / CMakeLists.txt
index 28ad707..1280f6d 100644 (file)
@@ -1,9 +1,13 @@
 
-spec2def(localspl localspl.spec ADD_IMPORTLIB)
+spec2def(localspl.dll localspl.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
+    jobs.c
     main.c
-    precomp.h)
+    precomp.h
+    printers.c
+    printprocessors.c
+    tools.c)
 
 add_library(localspl SHARED
     ${SOURCE}
@@ -13,6 +17,6 @@ add_library(localspl SHARED
 
 set_module_type(localspl win32dll UNICODE)
 target_link_libraries(localspl wine)
-add_importlibs(localspl kernel32 msvcrt ntdll)
+add_importlibs(localspl advapi32 msvcrt kernel32 ntdll)
 add_pch(localspl precomp.h SOURCE)
 add_cd_file(TARGET localspl DESTINATION reactos/system32 FOR all)