[WIN32SS]
[reactos.git] / reactos / win32ss / reactx / dxg / CMakeLists.txt
index 320055b..41a1c7e 100644 (file)
@@ -1,15 +1,19 @@
 
 spec2def(dxg.sys dxg.spec)
 
-add_library(dxg SHARED
+list(APPEND SOURCE
     main.c
     ddhmg.c
     eng.c
     historic.c
+    dxg_int.h)
+
+add_library(dxg SHARED
+    ${SOURCE}
     dxg.rc
     ${CMAKE_CURRENT_BINARY_DIR}/dxg.def)
 
 set_module_type(dxg kernelmodedriver)
 add_importlibs(dxg dxgthk ntoskrnl)
-add_pch(dxg dxg_int.h)
+add_pch(dxg dxg_int.h SOURCE)
 add_cd_file(TARGET dxg DESTINATION reactos/system32/drivers FOR all)