[GDI32_APITEST] Add tests for GetFontResourceInfoW. Patch by Katayama Hirofumi MZ...
[reactos.git] / rostests / apitests / gdi32 / CMakeLists.txt
index 3607d65..7c593eb 100644 (file)
@@ -22,8 +22,11 @@ list(APPEND SOURCE
     EngCreateSemaphore.c
     EngDeleteSemaphore.c
     EngReleaseSemaphore.c
+    EnumFontFamilies.c
     ExcludeClipRect.c
     ExtCreatePen.c
+    ExtCreateRegion.c
+    FrameRgn.c
     GdiConvertBitmap.c
     GdiConvertBrush.c
     GdiConvertDC.c
@@ -41,6 +44,8 @@ list(APPEND SOURCE
     GetCurrentObject.c
     GetDIBColorTable.c
     GetDIBits.c
+    GetFontResourceInfoW.c
+    GetGlyphIndices.c
     GetObject.c
     GetRandomRgn.c
     GetPixel.c
@@ -48,10 +53,15 @@ list(APPEND SOURCE
     GetTextExtentExPoint.c
     GetTextFace.c
     MaskBlt.c
+    NtGdiAddFontResource.c
     OffsetClipRgn.c
+    OffsetRgn.c
+    PaintRgn.c
     PatBlt.c
     Rectangle.c
+    RealizePalette.c
     SelectObject.c
+    SetBoundsRect.c
     SetBrushOrgEx.c
     SetDCPenColor.c
     SetDIBits.c
@@ -64,8 +74,8 @@ list(APPEND SOURCE
     init.c
     testlist.c)
 
-add_executable(gdi32_apitest ${SOURCE})
-target_link_libraries(gdi32_apitest ${PSEH_LIB})
+add_executable(gdi32_apitest ${SOURCE} resource.rc)
+target_link_libraries(gdi32_apitest ${PSEH_LIB} win32ksys)
 set_module_type(gdi32_apitest win32cui)
-add_importlibs(gdi32_apitest gdi32 user32 msvcrt kernel32)
-add_cd_file(TARGET gdi32_apitest DESTINATION reactos/bin FOR all)
+add_importlibs(gdi32_apitest gdi32 user32 msvcrt kernel32 ntdll)
+add_rostests_file(TARGET gdi32_apitest)