[GDI32_APITEST]
[reactos.git] / rostests / apitests / gdi32 / CMakeLists.txt
index adda045..b44193a 100644 (file)
@@ -1,16 +1,20 @@
 
-add_definitions(-D_DLL -D__USE_CRTIMP)
+include_directories(${REACTOS_SOURCE_DIR}/win32ss)
 
 list(APPEND SOURCE
     AddFontResource.c
     AddFontResourceEx.c
     BeginPath.c
+    CombineRgn.c
     CombineTransform.c
+    CreateBitmap.c
     CreateBitmapIndirect.c
     CreateCompatibleDC.c
     CreateDIBitmap.c
+    CreateDIBPatternBrush
     CreateFont.c
     CreateFontIndirect.c
+    CreateIconIndirect.c
     CreatePen.c
     CreateRectRgn.c
     DPtoLP.c
@@ -18,6 +22,8 @@ list(APPEND SOURCE
     EngCreateSemaphore.c
     EngDeleteSemaphore.c
     EngReleaseSemaphore.c
+    EnumFontFamilies.c
+    ExcludeClipRect.c
     ExtCreatePen.c
     GdiConvertBitmap.c
     GdiConvertBrush.c
@@ -31,27 +37,36 @@ list(APPEND SOURCE
     GdiGetLocalDC.c
     GdiReleaseLocalDC.c
     GdiSetAttrs.c
+    GetClipBox.c
     GetClipRgn.c
     GetCurrentObject.c
+    GetDIBColorTable.c
     GetDIBits.c
     GetObject.c
+    GetRandomRgn.c
     GetPixel.c
     GetStockObject.c
     GetTextExtentExPoint.c
     GetTextFace.c
     MaskBlt.c
+    OffsetClipRgn.c
+    PatBlt.c
     Rectangle.c
     SelectObject.c
+    SetBrushOrgEx.c
     SetDCPenColor.c
     SetDIBits.c
+    SetDIBitsToDevice.c
     SetMapMode.c
+    SetPixel.c
     SetSysColors.c
     SetWindowExtEx.c
     SetWorldTransform.c
+    init.c
     testlist.c)
 
 add_executable(gdi32_apitest ${SOURCE})
-target_link_libraries(gdi32_apitest wine ${PSEH_LIB})
+target_link_libraries(gdi32_apitest ${PSEH_LIB})
 set_module_type(gdi32_apitest win32cui)
-add_importlibs(gdi32_apitest gdi32 user32 msvcrt kernel32 ntdll)
+add_importlibs(gdi32_apitest gdi32 user32 msvcrt kernel32)
 add_cd_file(TARGET gdi32_apitest DESTINATION reactos/bin FOR all)