[KERNEL32_APITEST] Add tests that reveal how the GetComputerNameEx fix in r72722...
[reactos.git] / rostests / apitests / kernel32 / CMakeLists.txt
index ac6cae8..94c74ac 100644 (file)
@@ -2,6 +2,7 @@
 list(APPEND SOURCE
     dosdev.c
     FindFiles.c
+    GetComputerNameEx.c
     GetCurrentDirectory.c
     GetDriveType.c
     GetModuleFileName.c
@@ -12,10 +13,13 @@ list(APPEND SOURCE
     SetCurrentDirectory.c
     SetUnhandledExceptionFilter.c
     TerminateProcess.c
-    testlist.c)
+    TunnelCache.c
+    WideCharToMultiByte.c
+    testlist.c
+    Mailslot.c)
 
 add_executable(kernel32_apitest ${SOURCE})
 target_link_libraries(kernel32_apitest wine ${PSEH_LIB})
 set_module_type(kernel32_apitest win32cui)
-add_importlibs(kernel32_apitest gdi32 user32 shlwapi msvcrt kernel32 ntdll)
+add_importlibs(kernel32_apitest advapi32 gdi32 user32 shlwapi msvcrt kernel32 ntdll)
 add_cd_file(TARGET kernel32_apitest DESTINATION reactos/bin FOR all)