[KERNEL32_APITEST]: Internationalization console tests by Katayama Hirofumi MZ.
[reactos.git] / rostests / apitests / kernel32 / CMakeLists.txt
index a87c140..c6e2f48 100644 (file)
@@ -1,17 +1,46 @@
 
+add_subdirectory(redirptest)
+
 list(APPEND SOURCE
+    Console.c
+    DefaultActCtx.c
+    DeviceIoControl.c
+    dosdev.c
+    FindActCtxSectionStringW.c
     FindFiles.c
+    GetComputerNameEx.c
     GetCurrentDirectory.c
     GetDriveType.c
     GetModuleFileName.c
+    interlck.c
+    LoadLibraryExW.c
     lstrcpynW.c
+    lstrlen.c
     MultiByteToWideChar.c
+    PrivMoveFileIdentityW.c
+    SetConsoleWindowInfo.c
     SetCurrentDirectory.c
     SetUnhandledExceptionFilter.c
-    testlist.c)
+    TerminateProcess.c
+    TunnelCache.c
+    WideCharToMultiByte.c
+    testlist.c
+    Mailslot.c)
 
 add_executable(kernel32_apitest ${SOURCE})
 target_link_libraries(kernel32_apitest wine ${PSEH_LIB})
 set_module_type(kernel32_apitest win32cui)
-add_importlibs(kernel32_apitest gdi32 user32 shlwapi msvcrt kernel32 ntdll)
-add_cd_file(TARGET kernel32_apitest DESTINATION reactos/bin FOR all)
+add_delay_importlibs(kernel32_apitest advapi32 shlwapi)
+add_importlibs(kernel32_apitest msvcrt kernel32 ntdll)
+add_rostests_file(TARGET kernel32_apitest)
+
+list(APPEND MANIFEST_FILES
+    classtest.manifest
+    classtest2.manifest
+    comctl32dep.manifest
+    dep1.manifest
+    deptest.manifest)
+
+foreach(item ${MANIFEST_FILES})
+    add_rostests_file(FILE "${CMAKE_CURRENT_SOURCE_DIR}/${item}")
+endforeach(item)