[NTDLL_APITEST] Add tests for RtlpEnsureBufferSize. CORE-11990
[reactos.git] / rostests / apitests / ntdll / CMakeLists.txt
index 03309b8..538261f 100644 (file)
@@ -2,30 +2,51 @@
 list(APPEND SOURCE
     LdrEnumResources.c
     NtAllocateVirtualMemory.c
+    NtApphelpCacheControl.c
     NtContinue.c
     NtCreateFile.c
+    NtCreateKey.c
     NtCreateThread.c
     NtDeleteKey.c
     NtFreeVirtualMemory.c
     NtMapViewOfSection.c
     NtMutant.c
+    NtOpenProcessToken.c
+    NtOpenThreadToken.c
     NtProtectVirtualMemory.c
+    NtQueryInformationProcess.c
+    NtQueryKey.c
     NtQuerySystemEnvironmentValue.c
     NtQueryVolumeInformationFile.c
+    NtReadFile.c
     NtSaveKey.c
+    NtSetValueKey.c
+    NtWriteFile.c
+    RtlAllocateHeap.c
     RtlBitmap.c
+    RtlCopyMappedMemory.c
+    RtlDeleteAce.c
     RtlDetermineDosPathNameType.c
     RtlDoesFileExists.c
+    RtlDosApplyFileIsolationRedirection_Ustr.c
     RtlDosPathNameToNtPathName_U.c
     RtlDosSearchPath_U.c
     RtlDosSearchPath_Ustr.c
+    RtlFirstFreeAce.c
+    RtlGenerate8dot3Name.c
     RtlGetFullPathName_U.c
     RtlGetFullPathName_Ustr.c
     RtlGetFullPathName_UstrEx.c
     RtlGetLengthWithoutTrailingPathSeperators.c
     RtlGetLongestNtPathLength.c
+    RtlImageRvaToVa.c
     RtlInitializeBitMap.c
+    RtlIsNameLegalDOS8Dot3.c
     RtlMemoryStream.c
+    RtlpEnsureBufferSize.c
+    RtlReAllocateHeap.c
+    RtlUpcaseUnicodeStringToCountedOemString.c
+    StackOverflow.c
     SystemInfo.c
     Timer.c
     testlist.c)
@@ -43,4 +64,9 @@ if(NOT MSVC)
     set_source_files_properties(RtlGetFullPathName_UstrEx.c PROPERTIES COMPILE_FLAGS "-Wno-format")
 endif()
 
-add_cd_file(TARGET ntdll_apitest DESTINATION reactos/bin FOR all)
+add_rostests_file(TARGET ntdll_apitest)
+add_rostests_file(TARGET ntdll_apitest SUBDIR testdata)
+# These are empty files
+add_rostests_file(FILE "${CMAKE_CURRENT_SOURCE_DIR}/ntdll_apitest.exe.local" SUBDIR testdata)
+add_rostests_file(FILE "${CMAKE_CURRENT_SOURCE_DIR}/shell32.dll" SUBDIR testdata)
+add_rostests_file(FILE "${CMAKE_CURRENT_SOURCE_DIR}/test.dll" SUBDIR testdata)