[NTDLL_APITESTS]
[reactos.git] / rostests / apitests / ntdll / CMakeLists.txt
index 9404d89..7345855 100644 (file)
@@ -2,19 +2,30 @@
 list(APPEND SOURCE
     LdrEnumResources.c
     NtAllocateVirtualMemory.c
+    NtApphelpCacheControl.c
     NtContinue.c
     NtCreateFile.c
     NtCreateThread.c
+    NtDeleteKey.c
     NtFreeVirtualMemory.c
     NtMapViewOfSection.c
+    NtMutant.c
+    NtOpenProcessToken.c
+    NtOpenThreadToken.c
     NtProtectVirtualMemory.c
+    NtQueryKey.c
     NtQuerySystemEnvironmentValue.c
+    NtQueryVolumeInformationFile.c
+    NtSaveKey.c
+    RtlAllocateHeap.c
     RtlBitmap.c
+    RtlCopyMappedMemory.c
     RtlDetermineDosPathNameType.c
     RtlDoesFileExists.c
     RtlDosPathNameToNtPathName_U.c
     RtlDosSearchPath_U.c
     RtlDosSearchPath_Ustr.c
+    RtlGenerate8dot3Name.c
     RtlGetFullPathName_U.c
     RtlGetFullPathName_Ustr.c
     RtlGetFullPathName_UstrEx.c
@@ -22,6 +33,8 @@ list(APPEND SOURCE
     RtlGetLongestNtPathLength.c
     RtlInitializeBitMap.c
     RtlMemoryStream.c
+    RtlReAllocateHeap.c
+    StackOverflow.c
     SystemInfo.c
     Timer.c
     testlist.c)
@@ -36,9 +49,7 @@ set_module_type(ntdll_apitest win32cui)
 add_importlibs(ntdll_apitest msvcrt advapi32 kernel32 ntdll)
 
 if(NOT MSVC)
-    # FIXME: http://www.cmake.org/Bug/view.php?id=12998
-    #add_target_compile_flags(ntdll_apitest "-Wno-format")
-    set_source_files_properties(${SOURCE} PROPERTIES COMPILE_FLAGS "-Wno-format")
+    set_source_files_properties(RtlGetFullPathName_UstrEx.c PROPERTIES COMPILE_FLAGS "-Wno-format")
 endif()
 
 add_cd_file(TARGET ntdll_apitest DESTINATION reactos/bin FOR all)