[NTDLL_APITEST]
[reactos.git] / rostests / apitests / ntdll / CMakeLists.txt
index 1a8b055..c13df84 100644 (file)
@@ -2,6 +2,15 @@
 list(APPEND SOURCE
     NtAllocateVirtualMemory.c
     NtFreeVirtualMemory.c
+    RtlBitmap.c
+    RtlDetermineDosPathNameType.c
+    RtlDoesFileExists.c
+    RtlDosSearchPath_U.c
+    RtlDosSearchPath_Ustr.c
+    RtlGetFullPathName_U.c
+    RtlGetFullPathName_Ustr.c
+    RtlGetFullPathName_UstrEx.c
+    RtlGetLongestNtPathLength.c
     RtlInitializeBitMap.c
     SystemInfo.c
     ZwContinue.c
@@ -12,7 +21,14 @@ if(ARCH MATCHES i386)
 endif()
 
 add_executable(ntdll_apitest ${SOURCE})
-target_link_libraries(ntdll_apitest wine)
+target_link_libraries(ntdll_apitest wine ${PSEH_LIB})
 set_module_type(ntdll_apitest win32cui)
 add_importlibs(ntdll_apitest msvcrt advapi32 kernel32 ntdll)
+
+if(NOT MSVC)
+    # FIXME: http://www.cmake.org/Bug/view.php?id=12998
+    #add_target_compile_flags(ntdll_apitest "-Wno-format")
+    set_source_files_properties(${SOURCE} PROPERTIES COMPILE_FLAGS "-Wno-format")
+endif()
+
 add_cd_file(TARGET ntdll_apitest DESTINATION reactos/bin FOR all)