[SHELL32_APITEST] -Add some tests for SHParseDisplayName for CORE-12882.
[reactos.git] / rostests / apitests / powrprof / CMakeLists.txt
index c00d778..c5ffa44 100644 (file)
@@ -1,13 +1,5 @@
 
-add_definitions(
-    -D__ROS_LONG64__
-    -D_UNICODE -DUNICODE)
-
 add_executable(powrprof_apitest power.c testlist.c)
 set_module_type(powrprof_apitest win32cui)
-add_importlibs(powrprof_apitest advapi32 powrprof msvcrt kernel32 ntdll)
-add_cd_file(TARGET powrprof_apitest DESTINATION reactos/bin FOR all)
-
-if(NOT MSVC)
-    allow_warnings(powrprof_apitest)
-endif()
+add_importlibs(powrprof_apitest advapi32 powrprof msvcrt kernel32)
+add_rostests_file(TARGET powrprof_apitest)