[SHELL32_APITEST] -Add some tests for SHParseDisplayName for CORE-12882.
[reactos.git] / rostests / apitests / shell32 / CMakeLists.txt
index 81e334c..a9b8bfa 100644 (file)
@@ -1,12 +1,19 @@
 
 set_cpp(WITH_RUNTIME)
 
-list(APPEND SOURCE
-   menu.cpp
-   testlist.c)
+include_directories(${REACTOS_SOURCE_DIR}/sdk/lib/atl)
 
-add_executable(shell32_apitest ${SOURCE})
-target_link_libraries(shell32_apitest wine uuid)
+add_executable(shell32_apitest
+    CFSFolder.cpp
+    CMyComputer.cpp
+    CShellDesktop.cpp
+    CShellLink.cpp
+    menu.cpp
+    ShellExecuteEx.cpp
+    shelltest.cpp
+    SHParseDisplayName.cpp
+    testlist.c)
+target_link_libraries(shell32_apitest wine uuid ${PSEH_LIB})
 set_module_type(shell32_apitest win32cui)
-add_importlibs(shell32_apitest msvcrt kernel32 user32 gdi32 shell32 ole32 shlwapi)
-add_cd_file(TARGET shell32_apitest DESTINATION reactos/bin FOR all)
+add_importlibs(shell32_apitest user32 gdi32 shell32 ole32 oleaut32 advapi32 shlwapi msvcrt kernel32 ntdll)
+add_rostests_file(TARGET shell32_apitest)