Git conversion: Make reactos the root directory, move rosapps, rostests, wallpapers...
[reactos.git] / rostests / apitests / win32nt / CMakeLists.txt
diff --git a/rostests/apitests/win32nt/CMakeLists.txt b/rostests/apitests/win32nt/CMakeLists.txt
deleted file mode 100644 (file)
index a3ffa1c..0000000
+++ /dev/null
@@ -1,81 +0,0 @@
-
-add_definitions(-D_DLL -D__USE_CRTIMP)
-include_directories(${REACTOS_SOURCE_DIR}/win32ss/include ../gditools)
-
-list(APPEND SOURCE
-    ntdd/NtGdiDdCreateDirectDrawObject.c
-    ntdd/NtGdiDdDeleteDirectDrawObject.c
-    ntdd/NtGdiDdQueryDirectDrawObject.c
-
-    ntgdi/NtGdiArcInternal.c
-    ntgdi/NtGdiBitBlt.c
-    ntgdi/NtGdiCombineRgn.c
-    ntgdi/NtGdiCreateBitmap.c
-    ntgdi/NtGdiCreateCompatibleBitmap.c
-    ntgdi/NtGdiCreateCompatibleDC.c
-    ntgdi/NtGdiCreateDIBSection.c
-    ntgdi/NtGdiDeleteObjectApp.c
-    ntgdi/NtGdiDoPalette.c
-    ntgdi/NtGdiEngCreatePalette.c
-    ntgdi/NtGdiEnumFontOpen.c
-    #ntgdi/NtGdiExtSelectClipRgn.c
-    ntgdi/NtGdiExtTextOutW.c
-    #ntgdi/NtGdiFlushUserBatch.c
-    ntgdi/NtGdiGetBitmapBits.c
-    ntgdi/NtGdiGetDIBits.c
-    ntgdi/NtGdiGetFontResourceInfoInternalW.c
-    ntgdi/NtGdiGetRandomRgn.c
-    ntgdi/NtGdiGetStockObject.c
-    ntgdi/NtGdiPolyPolyDraw.c
-    ntgdi/NtGdiRestoreDC.c
-    ntgdi/NtGdiSaveDC.c
-    ntgdi/NtGdiSelectBitmap.c
-    ntgdi/NtGdiSelectBrush.c
-    ntgdi/NtGdiSelectFont.c
-    ntgdi/NtGdiSelectPen.c
-    ntgdi/NtGdiSetBitmapBits.c
-    ntgdi/NtGdiSetDIBitsToDeviceInternal.c
-
-#    ntuser/NtUserCallHwnd.c
-#    ntuser/NtUserCallHwndLock.c
-#    ntuser/NtUserCallHwndOpt.c
-#    ntuser/NtUserCallHwndParam.c
-#    ntuser/NtUserCallHwndParamLock.c
-#    ntuser/NtUserCallNoParam.c
-#    ntuser/NtUserCallOneParam.c
-    ntuser/NtUserCountClipboardFormats.c
-    ntuser/NtUserCreateWindowEx.c
-#    ntuser/NtUserEnumDisplayMonitors.c
-    ntuser/NtUserEnumDisplaySettings.c
-    ntuser/NtUserFindExistingCursorIcon.c
-    ntuser/NtUserGetClassInfo.c
-#    ntuser/NtUserGetIconInfo.c
-    ntuser/NtUserGetTitleBarInfo.c
-    ntuser/NtUserProcessConnect.c
-    ntuser/NtUserRedrawWindow.c
-    ntuser/NtUserScrollDC.c
-    ntuser/NtUserSelectPalette.c
-    ntuser/NtUserSetTimer.c
-    ntuser/NtUserSystemParametersInfo.c
-    ntuser/NtUserToUnicodeEx.c
-    ntuser/NtUserUpdatePerUserSystemParameters.c
-
-    #osver.c
-    testlist.c
-    w32knapi.rc)
-
-add_executable(win32knt_apitest ${SOURCE})
-target_link_libraries(win32knt_apitest ${PSEH_LIB} gditools)
-set_module_type(win32knt_apitest win32cui)
-add_importlibs(win32knt_apitest
-    win32u # win32u_2ksp4 win32u_xpsp2 win32u_2k3sp2 win32u_vista
-    gdi32
-    user32
-    shell32
-    advapi32
-    msvcrt
-    kernel32
-    ntdll)
-
-add_dependencies(win32knt_apitest xdk)
-add_rostests_file(TARGET win32knt_apitest)