[WIN32U] Rename win32kdll to win32u, which is the "official" name on Windows 10
[reactos.git] / rostests / apitests / win32u / win32u_vista / CMakeLists.txt
diff --git a/rostests/apitests/win32u/win32u_vista/CMakeLists.txt b/rostests/apitests/win32u/win32u_vista/CMakeLists.txt
new file mode 100644 (file)
index 0000000..1036065
--- /dev/null
@@ -0,0 +1,11 @@
+
+spec2def(win32u_vista.spec win32u_vista.spec ADD_IMPORTLIB)
+add_asm_files(win32u_vista_asm win32u_vista.S)
+
+add_library(win32u_vista SHARED
+    main.c
+    ${win32u_vista_asm}
+    ${CMAKE_CURRENT_BINARY_DIR}/win32u_vista.def)
+
+set_module_type(win32u_vista module)
+add_dependencies(win32u_vista psdk)