[WS2_32_APITESTS] Add some bind API tests
[reactos.git] / rostests / apitests / ws2_32 / CMakeLists.txt
index 13ef03b..1fb80b6 100644 (file)
@@ -1,15 +1,28 @@
 
 list(APPEND SOURCE
+    bind.c
     getaddrinfo.c
+    getnameinfo.c
+    getservbyname.c
+    getservbyport.c
     helpers.c
     ioctlsocket.c
+    nonblocking.c
     nostartup.c
     recv.c
+    send.c
+    WSAAsync.c
+    WSAIoctl.c
+    WSARecv.c
     WSAStartup.c
     testlist.c)
 
 add_executable(ws2_32_apitest ${SOURCE})
 target_link_libraries(ws2_32_apitest wine ${PSEH_LIB})
 set_module_type(ws2_32_apitest win32cui)
-add_importlibs(ws2_32_apitest ws2_32 msvcrt kernel32 ntdll)
-add_cd_file(TARGET ws2_32_apitest DESTINATION reactos/bin FOR all)
+add_importlibs(ws2_32_apitest ws2_32 msvcrt iphlpapi kernel32 ntdll)
+add_rostests_file(TARGET ws2_32_apitest)
+
+if((NOT MSVC) AND (NOT CMAKE_C_COMPILER_ID STREQUAL "Clang"))
+    add_target_compile_flags(ws2_32_apitest "-Wno-missing-braces")
+endif()