[KMTESTS:NPFS]
[reactos.git] / rostests / kmtests / CMakeLists.txt
index 7381667..11d1369 100644 (file)
@@ -12,7 +12,9 @@ list(APPEND COMMON_SOURCE
     example/GuardedMemory.c
     rtl/RtlAvlTree.c
     rtl/RtlException.c
+    rtl/RtlIntSafe.c
     rtl/RtlMemory.c
+    rtl/RtlRegistry.c
     rtl/RtlSplayTree.c
     rtl/RtlUnicodeString.c)
 
@@ -20,11 +22,16 @@ list(APPEND COMMON_SOURCE
 # kmtest_drv.sys driver
 #
 list(APPEND KMTEST_DRV_SOURCE
+    kmtest_drv/guid.c
     kmtest_drv/kmtest_drv.c
     kmtest_drv/testlist.c
 
     example/Example.c
     example/KernelType.c
+    npfs/NpfsConnect.c
+    npfs/NpfsCreate.c
+    npfs/NpfsHelpers.c
+    npfs/NpfsReadWrite.c
     ntos_ex/ExCallback.c
     ntos_ex/ExDoubleList.c
     ntos_ex/ExFastMutex.c
@@ -37,12 +44,14 @@ list(APPEND KMTEST_DRV_SOURCE
     ntos_ex/ExTimer.c
     ntos_fsrtl/FsRtlExpression.c
     ntos_fsrtl/FsRtlMcb.c
+    ntos_fsrtl/FsRtlTunnel.c
     ntos_io/IoDeviceInterface.c
     ntos_io/IoEvent.c
     ntos_io/IoInterrupt.c
     ntos_io/IoIrp.c
     ntos_io/IoMdl.c
     ntos_ke/KeApc.c
+    ntos_ke/KeDevQueue.c
     ntos_ke/KeDpc.c
     ntos_ke/KeEvent.c
     ntos_ke/KeGuardedMutex.c
@@ -59,6 +68,7 @@ list(APPEND KMTEST_DRV_SOURCE
     ntos_ob/ObType.c
     ntos_ob/ObTypes.c
     ntos_ps/PsNotify.c
+    ntos_se/SeQueryInfoToken.c
     ${COMMON_SOURCE}
 
     kmtest_drv/kmtest_drv.rc)