[KERNEL32_APITEST] - Add tests for LoadLibraryExW to test its ability to load a redir...
[reactos.git] / rostests / kmtests / CMakeLists.txt
index 4f767fb..8fe2101 100644 (file)
@@ -8,6 +8,7 @@ add_subdirectory(example)
 add_subdirectory(kernel32)
 add_subdirectory(ntos_cc)
 add_subdirectory(ntos_io)
+add_subdirectory(ntos_mm)
 add_subdirectory(ntos_po)
 add_subdirectory(tcpip)
 
@@ -100,7 +101,7 @@ add_importlibs(kmtest_drv ntoskrnl hal)
 add_dependencies(kmtest_drv bugcodes xdk)
 add_target_compile_definitions(kmtest_drv KMT_KERNEL_MODE NTDDI_VERSION=NTDDI_WS03SP1)
 #add_pch(kmtest_drv include/kmt_test.h)
-add_cd_file(TARGET kmtest_drv DESTINATION reactos/bin FOR all)
+add_rostests_file(TARGET kmtest_drv)
 
 add_library(kmtest_printf
     kmtest_drv/printf_stubs.c
@@ -126,6 +127,7 @@ list(APPEND KMTEST_SOURCE
     ntos_io/IoCreateFile_user.c
     ntos_io/IoDeviceObject_user.c
     ntos_io/IoReadWrite_user.c
+    ntos_mm/NtCreateSection_user.c
     ntos_po/PoIrp_user.c
     tcpip/TcpIp_user.c
     ${COMMON_SOURCE}
@@ -139,6 +141,7 @@ add_importlibs(kmtest advapi32 ws2_32 msvcrt kernel32 ntdll)
 add_target_compile_definitions(kmtest KMT_USER_MODE)
 #add_pch(kmtest include/kmt_test.h)
 set_target_properties(kmtest PROPERTIES OUTPUT_NAME "kmtest_")
+#add_rostests_file(TARGET kmtest)
 add_cd_file(TARGET kmtest DESTINATION reactos/bin FOR all)
 
 #
@@ -153,6 +156,7 @@ add_dependencies(kmtest_drivers
     iodeviceobject_drv
     iohelper_drv
     ioreadwrite_drv
+    ntcreatesection_drv
     poirp_drv
     tcpip_drv
     cccopyread_drv)