[CRYPT32]
[reactos.git] / rostests / kmtests / CMakeLists.txt
index b503992..90987fd 100644 (file)
@@ -12,7 +12,9 @@ list(APPEND COMMON_SOURCE
     example/GuardedMemory.c
     rtl/RtlAvlTree.c
     rtl/RtlException.c
+    rtl/RtlIntSafe.c
     rtl/RtlMemory.c
+    rtl/RtlRegistry.c
     rtl/RtlSplayTree.c
     rtl/RtlUnicodeString.c)
 
@@ -20,11 +22,18 @@ list(APPEND COMMON_SOURCE
 # kmtest_drv.sys driver
 #
 list(APPEND KMTEST_DRV_SOURCE
+    kmtest_drv/guid.c
     kmtest_drv/kmtest_drv.c
     kmtest_drv/testlist.c
 
     example/Example.c
     example/KernelType.c
+    npfs/NpfsConnect.c
+    npfs/NpfsCreate.c
+    npfs/NpfsFileInfo.c
+    npfs/NpfsHelpers.c
+    npfs/NpfsReadWrite.c
+    npfs/NpfsVolumeInfo.c
     ntos_ex/ExCallback.c
     ntos_ex/ExDoubleList.c
     ntos_ex/ExFastMutex.c
@@ -36,12 +45,16 @@ list(APPEND KMTEST_DRV_SOURCE
     ntos_ex/ExSingleList.c
     ntos_ex/ExTimer.c
     ntos_fsrtl/FsRtlExpression.c
+    ntos_fsrtl/FsRtlMcb.c
+    ntos_fsrtl/FsRtlTunnel.c
+    ntos_io/IoCreateFile.c
     ntos_io/IoDeviceInterface.c
     ntos_io/IoEvent.c
     ntos_io/IoInterrupt.c
     ntos_io/IoIrp.c
     ntos_io/IoMdl.c
     ntos_ke/KeApc.c
+    ntos_ke/KeDevQueue.c
     ntos_ke/KeDpc.c
     ntos_ke/KeEvent.c
     ntos_ke/KeGuardedMutex.c
@@ -51,10 +64,14 @@ list(APPEND KMTEST_DRV_SOURCE
     ntos_ke/KeSpinLock.c
     ntos_ke/KeTimer.c
     ntos_mm/MmSection.c
+    ntos_mm/ZwAllocateVirtualMemory.c
+    ntos_mm/ZwCreateSection.c
+    ntos_mm/ZwMapViewOfSection.c
     ntos_ob/ObReference.c
     ntos_ob/ObType.c
     ntos_ob/ObTypes.c
     ntos_ps/PsNotify.c
+    ntos_se/SeQueryInfoToken.c
     ${COMMON_SOURCE}
 
     kmtest_drv/kmtest_drv.rc)
@@ -64,6 +81,7 @@ add_library(kmtest_drv SHARED ${KMTEST_DRV_SOURCE})
 set_module_type(kmtest_drv kernelmodedriver)
 target_link_libraries(kmtest_drv kmtest_printf chkstk ${PSEH_LIB})
 add_importlibs(kmtest_drv ntoskrnl hal)
+add_dependencies(kmtest_drv bugcodes)
 add_target_compile_definitions(kmtest_drv KMT_KERNEL_MODE NTDDI_VERSION=NTDDI_WS03SP1)
 #add_pch(kmtest_drv include/kmt_test.h)