[USP10_WINETEST] Sync with Wine Staging 2.9. CORE-13362
[reactos.git] / rostests / kmtests / ntos_io / CMakeLists.txt
index af43acf..76edbd5 100644 (file)
@@ -1,5 +1,20 @@
-include_directories(
-    ../include)
+
+include_directories(../include)
+
+#
+# IoCreateFile
+#
+list(APPEND IOCREATEFILE_DRV_SOURCE
+    ../kmtest_drv/kmtest_standalone.c
+    IoCreateFile_drv.c)
+
+add_library(iocreatefile_drv SHARED ${IOCREATEFILE_DRV_SOURCE})
+set_module_type(iocreatefile_drv kernelmodedriver)
+target_link_libraries(iocreatefile_drv kmtest_printf ${PSEH_LIB})
+add_importlibs(iocreatefile_drv ntoskrnl hal)
+add_target_compile_definitions(iocreatefile_drv KMT_STANDALONE_DRIVER)
+#add_pch(iocreatefile_drv ../include/kmt_test.h)
+add_rostests_file(TARGET iocreatefile_drv)
 
 #
 # IoDeviceObject
@@ -9,14 +24,12 @@ list(APPEND IODEVICEOBJECT_DRV_SOURCE
     IoDeviceObject_drv.c)
 
 add_library(iodeviceobject_drv SHARED ${IODEVICEOBJECT_DRV_SOURCE})
-
 set_module_type(iodeviceobject_drv kernelmodedriver)
 target_link_libraries(iodeviceobject_drv kmtest_printf ${PSEH_LIB})
 add_importlibs(iodeviceobject_drv ntoskrnl hal)
 add_target_compile_definitions(iodeviceobject_drv KMT_STANDALONE_DRIVER)
 #add_pch(iodeviceobject_drv ../include/kmt_test.h)
-
-add_cd_file(TARGET iodeviceobject_drv DESTINATION reactos/bin FOR all)
+add_rostests_file(TARGET iodeviceobject_drv)
 
 #
 # IoHelper
@@ -26,11 +39,24 @@ list(APPEND IOHELPER_DRV_SOURCE
     IoHelper_drv.c)
 
 add_library(iohelper_drv SHARED ${IOHELPER_DRV_SOURCE})
-
 set_module_type(iohelper_drv kernelmodedriver)
 target_link_libraries(iohelper_drv kmtest_printf ${PSEH_LIB})
 add_importlibs(iohelper_drv ntoskrnl hal)
 add_target_compile_definitions(iohelper_drv KMT_STANDALONE_DRIVER)
 #add_pch(iohelper_drv ../include/kmt_test.h)
+add_rostests_file(TARGET iohelper_drv)
 
-add_cd_file(TARGET iohelper_drv DESTINATION reactos/bin FOR all)
+#
+# IoReadWrite
+#
+list(APPEND IOREADWRITE_DRV_SOURCE
+    ../kmtest_drv/kmtest_standalone.c
+    IoReadWrite_drv.c)
+
+add_library(ioreadwrite_drv SHARED ${IOREADWRITE_DRV_SOURCE})
+set_module_type(ioreadwrite_drv kernelmodedriver)
+target_link_libraries(ioreadwrite_drv kmtest_printf ${PSEH_LIB})
+add_importlibs(ioreadwrite_drv ntoskrnl hal)
+add_target_compile_definitions(ioreadwrite_drv KMT_STANDALONE_DRIVER)
+#add_pch(ioreadwrite_drv ../include/kmt_test.h)
+add_rostests_file(TARGET ioreadwrite_drv)