[KERNEL32_TEST]
[reactos.git] / rostests / winetests / kernel32 / CMakeLists.txt
index 5a26ce1..2eec893 100644 (file)
@@ -1,12 +1,9 @@
 
 add_definitions(
-    -D__ROS_LONG64__
-    -D_DLL -D__USE_CRTIMP)
+    -D__ROS_LONG64__)
 
 remove_definitions(-DWINVER=0x502 -D_WIN32_IE=0x600 -D_WIN32_WINNT=0x502)
 
-set_rc_compiler()
-
 list(APPEND SOURCE
     actctx.c
     alloc.c
@@ -24,7 +21,6 @@ list(APPEND SOURCE
     format_msg.c
     #generated.c
     heap.c
-    interlck.c
     loader.c
     locale.c
     mailslot.c
@@ -42,16 +38,14 @@ list(APPEND SOURCE
     version.c
     virtual.c
     volume.c
-    dosdev.c
-    testlist.c
+    testlist.c)
+
+add_executable(kernel32_winetest
+    ${SOURCE}
     resource.rc)
 
-add_executable(kernel32_winetest ${SOURCE})
 target_link_libraries(kernel32_winetest wine)
 set_module_type(kernel32_winetest win32cui)
 add_importlibs(kernel32_winetest user32 advapi32 msvcrt kernel32 ntdll)
-if(NOT MSVC)
-    allow_warnings(kernel32_winetest)
-endif()
 
-add_cd_file(TARGET kernel32_winetest DESTINATION reactos/bin FOR all)
\ No newline at end of file
+add_cd_file(TARGET kernel32_winetest DESTINATION reactos/bin FOR all)