[QUARTZ_WINETEST]
[reactos.git] / rostests / winetests / quartz / CMakeLists.txt
index c21b0b6..086628c 100644 (file)
@@ -1,8 +1,4 @@
 
-add_definitions(
-    -D__ROS_LONG64__
-    -D_DLL -D__USE_CRTIMP)
-
 list(APPEND SOURCE
     avisplitter.c
     dsoundrender.c
@@ -14,8 +10,13 @@ list(APPEND SOURCE
     videorenderer.c
     testlist.c)
 
+add_idl_headers(quartz_test_idlheader fil_data.idl)
 add_executable(quartz_winetest ${SOURCE})
-target_link_libraries(quartz_winetest wine)
+target_link_libraries(quartz_winetest uuid)
+add_dependencies(quartz_winetest quartz_test_idlheader)
 set_module_type(quartz_winetest win32cui)
-add_importlibs(quartz_winetest ole32 oleaut32 advapi32 msvcrt kernel32 ntdll)
-add_cab_target(quartz_winetest 7)
+add_importlibs(quartz_winetest ole32 oleaut32 advapi32 msvcrt kernel32)
+if(MSVC)
+    add_importlibs(quartz_winetest ntdll)
+endif()
+add_cd_file(TARGET quartz_winetest DESTINATION reactos/bin FOR all)