[WINETESTS]
[reactos.git] / rostests / winetests / user32 / CMakeLists.txt
index c1a45e0..7759513 100644 (file)
@@ -1,10 +1,4 @@
 
-add_definitions(
-    -D__ROS_LONG64__
-    -D_DLL -D__USE_CRTIMP)
-
-set_rc_compiler()
-
 list(APPEND SOURCE
     broadcast.c
     class.c
@@ -30,11 +24,9 @@ list(APPEND SOURCE
     win.c
     winstation.c
     wsprintf.c
-    testlist.c
-    resource.rc)
+    testlist.c)
 
-add_executable(user32_winetest ${SOURCE})
-target_link_libraries(user32_winetest wine)
+add_executable(user32_winetest ${SOURCE} resource.rc)
 set_module_type(user32_winetest win32cui)
-add_importlibs(user32_winetest user32 gdi32 advapi32 msvcrt kernel32 ntdll)
+add_importlibs(user32_winetest user32 gdi32 advapi32 msvcrt kernel32)
 add_cd_file(TARGET user32_winetest DESTINATION reactos/bin FOR all)