[ROSTESTS]
[reactos.git] / rostests / winetests / winmm / CMakeLists.txt
index 49d42ff..914ee71 100644 (file)
@@ -1,7 +1,5 @@
 
-add_definitions(
-    -D__ROS_LONG64__
-    -D_DLL -D__USE_CRTIMP)
+add_definitions(-D__ROS_LONG64__)
 
 list(APPEND SOURCE
     capture.c
@@ -16,3 +14,8 @@ add_executable(winmm_winetest ${SOURCE})
 target_link_libraries(winmm_winetest wine dxguid)
 set_module_type(winmm_winetest win32cui)
 add_importlibs(winmm_winetest winmm user32 msvcrt kernel32 ntdll)
+add_cd_file(TARGET winmm_winetest DESTINATION reactos/bin FOR all)
+
+if(NOT MSVC)
+    add_target_compile_flags(winmm_winetest "-Wno-format -Wno-unused-but-set-variable")
+endif()