* Addendum to r57875.
[reactos.git] / rostests / winetests / xmllite / CMakeLists.txt
index 821dfb4..91e6f98 100644 (file)
@@ -1,10 +1,19 @@
 
-add_definitions(
-    -D__ROS_LONG64__
-    -D_DLL -D__USE_CRTIMP)
+add_definitions(-D__ROS_LONG64__)
 
-add_executable(xmllite_winetest reader.c testlist.c)
-target_link_libraries(xmllite_winetest wine)
+list(APPEND SOURCE
+    reader.c
+    writer.c
+    testlist.c)
+
+if(NOT MSVC)
+    # FIXME: http://www.cmake.org/Bug/view.php?id=12998
+    #allow_warnings(xmllite_winetest)
+    set_source_files_properties(${SOURCE} PROPERTIES COMPILE_FLAGS "-Wno-error")
+endif()
+
+add_executable(xmllite_winetest ${SOURCE})
+target_link_libraries(xmllite_winetest wine uuid)
 set_module_type(xmllite_winetest win32cui)
 add_importlibs(xmllite_winetest xmllite ole32 msvcrt kernel32 ntdll)
-add_cab_target(xmllite_winetest 7)
+add_cd_file(TARGET xmllite_winetest DESTINATION reactos/bin FOR all)