Oups, forgot to link against advapi32 too (for registry functions) xD
[reactos.git] / subsystems / ntvdm / CMakeLists.txt
index 47d5755..43969dc 100644 (file)
@@ -1,19 +1,29 @@
 
-include_directories(.)
+include_directories(${REACTOS_SOURCE_DIR}/include/reactos/libs/fast486)
 
-set_rc_compiler()
+spec2def(ntvdm.exe ntvdm.spec)
 
-add_executable(ntvdm
+list(APPEND SOURCE
+    bios.c
+    bop.c
+    cmos.c
+    dos.c
+    emulator.c
+    int32.c
+    io.c
+    pic.c
+    ps2.c
+    registers.c
+    speaker.c
+    timer.c
+    vddsup.c
+    vga.c
     ntvdm.c
-    ntvdm.rc)
+    ntvdm.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/ntvdm.def)
 
-set_module_type(ntvdm win32cui)
-
-target_link_libraries(ntvdm
-    mingw_main
-    mingw_common)
-
-add_importlibs(ntvdm ntdll user32 gdi32 advapi32 kernel32 msvcrt)
-add_dependencies(ntvdm ndk bugcodes)
-
-add_cab_target(ntvdm 1)
\ No newline at end of file
+add_executable(ntvdm ${SOURCE})
+set_module_type(ntvdm win32cui UNICODE)
+target_link_libraries(ntvdm fast486)
+add_importlibs(ntvdm user32 gdi32 advapi32 msvcrt kernel32 ntdll)
+add_cd_file(TARGET ntvdm DESTINATION reactos/system32 FOR all)