Oups, forgot to link against advapi32 too (for registry functions) xD
[reactos.git] / subsystems / ntvdm / CMakeLists.txt
index 5be07e4..43969dc 100644 (file)
@@ -1,16 +1,22 @@
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/libs/softx86)
+include_directories(${REACTOS_SOURCE_DIR}/include/reactos/libs/fast486)
 
 spec2def(ntvdm.exe ntvdm.spec)
 
 list(APPEND SOURCE
     bios.c
+    bop.c
+    cmos.c
     dos.c
     emulator.c
+    int32.c
+    io.c
     pic.c
+    ps2.c
     registers.c
+    speaker.c
     timer.c
-    ps2.c
+    vddsup.c
     vga.c
     ntvdm.c
     ntvdm.rc
@@ -18,7 +24,6 @@ list(APPEND SOURCE
 
 add_executable(ntvdm ${SOURCE})
 set_module_type(ntvdm win32cui UNICODE)
-target_link_libraries(ntvdm softx86 softx87)
-add_importlibs(ntvdm msvcrt user32 kernel32 ntdll)
-add_dependencies(ntvdm softx86 softx87)
+target_link_libraries(ntvdm fast486)
+add_importlibs(ntvdm user32 gdi32 advapi32 msvcrt kernel32 ntdll)
 add_cd_file(TARGET ntvdm DESTINATION reactos/system32 FOR all)