Oups, forgot to link against advapi32 too (for registry functions) xD
[reactos.git] / subsystems / ntvdm / CMakeLists.txt
index accf3f7..43969dc 100644 (file)
@@ -5,12 +5,18 @@ spec2def(ntvdm.exe ntvdm.spec)
 
 list(APPEND SOURCE
     bios.c
+    bop.c
+    cmos.c
     dos.c
     emulator.c
+    int32.c
+    io.c
     pic.c
+    ps2.c
     registers.c
+    speaker.c
     timer.c
-    ps2.c
+    vddsup.c
     vga.c
     ntvdm.c
     ntvdm.rc
@@ -19,5 +25,5 @@ list(APPEND SOURCE
 add_executable(ntvdm ${SOURCE})
 set_module_type(ntvdm win32cui UNICODE)
 target_link_libraries(ntvdm fast486)
-add_importlibs(ntvdm msvcrt user32 gdi32 kernel32 ntdll)
+add_importlibs(ntvdm user32 gdi32 advapi32 msvcrt kernel32 ntdll)
 add_cd_file(TARGET ntvdm DESTINATION reactos/system32 FOR all)