[CMAKE] Turn import libs into regular C static libs
[reactos.git] / win32ss / user / user32 / CMakeLists.txt
index 0d38852..fb2655d 100644 (file)
@@ -82,9 +82,8 @@ set_module_type(user32 win32dll ENTRYPOINT DllMain 12 UNICODE)
 target_link_libraries(user32 user32_wsprintf wine win32ksys ${PSEH_LIB})
 add_dependencies(user32 asm)
 
-if(MSVC)
-    # for __ftol2_sse, float to int cast helper
-    target_link_libraries(user32 msvcrtex)
+if(MSVC AND (ARCH STREQUAL "i386"))
+    target_sources(user32 PRIVATE $<TARGET_OBJECTS:ftol2_sse>)
 endif()
 
 add_delay_importlibs(user32 imm32 usp10)